Why am I having multiple new radiator failures?

Automotive questions for anything about engines.
Post Reply
ashley
Posts: 2
Joined: Mon Jul 28, 2014 8:23 am

Why am I having multiple new radiator failures?

Post by ashley » Mon Jul 28, 2014 8:35 am

I own an 04 runner, 4.0 sr5. I have put 2 radiators in in the past week, both have failed at the same place. Driver's side bottom near the drain valve. First one was my bad, bought it from Amazon for cheap and made it maybe 20 miles before leaking and heating up but stopped truck before it reached the red and had it towed. Second was from Napa and made it a whole 200 miles before the dripping started. I am interested to know why this is an issue for me and if it's common.
Background: No it's not a gasket failure since I did 3 block checks a few weeks ago and they all passed. Thermostat works. Water pump works, water is circulating through the system and their aren't air bubbles. Not leaking coolant and not overheating either. Just very very VERY frustrated. Love my truck it's my baby but I'm hating it right now. Every week (LITERALLY) it's something new that goes wrong that I have to fix. I'm seriously considering selling it and buying something else. Very depressing

User avatar
Terry
Posts: 111
Joined: Sun Jan 05, 2014 9:05 pm

Re: Why am I having multiple new radiator failures?

Post by Terry » Tue Aug 05, 2014 4:29 pm

It is very odd to have 2 radiators fail in the same spot. My guess is that the one from Amazon and the one from Autozone were just from the same manufacturer and they just have a problem with that particular radiator. Just because they were purchased from different sources, does not mean they did not come from the same company.

That said, if the original radiator also failed in the same spot, you need to look closely at the mounting area in that spot. There may be something that is rubbing on that same part of the radiator.

ashley
Posts: 2
Joined: Mon Jul 28, 2014 8:23 am

Re: Why am I having multiple new radiator failures?

Post by ashley » Wed Aug 06, 2014 10:32 am

Thanks for your reply, the original didn't fail the same way it was just old and needed to be replaced. Ended up going to a more reputable source on the island and so far so good. Actually took the truck back to the place I bought radiator and the tech guy looked at it and said that everything looks fine. I'm thinking positive; it looks like it's going to be fine!

User avatar
Terry
Posts: 111
Joined: Sun Jan 05, 2014 9:05 pm

Re: Why am I having multiple new radiator failures?

Post by Terry » Fri Aug 15, 2014 4:07 pm

Yes, i think you should be fine no that using a different brand radiator.

Post Reply